Announcement Announcement Module
Collapse
No announcement yet.
Intellis Water Softener Woes Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Intellis Water Softener Woes

    I'm having problems with an Intellis water softener, about 10 years old. First, we would get a big slug of salty water every time it would regenerate (which I would have to manually flush out). Now, it uses VERY little salt, does not refill the brine tank properly, and does not soften adequately.

    I tore the control head completely apart and cleaned everything (the cylindrical screen at the brine inlet was almost plugged with iron deposits). I greased all the seals and O-rings with silicone grease and reassembled it. Still no good.

    I watched as it recycles, and it appears that the control valve is not moving correctly. There are four steps in regeneration: 1) Backwash, 2) Brine, 3) Rapid Rinse, and 4) Brine Refill. The valve moves correctly for steps 1 and 2. But when the control changes to step 3 (and 4), the motor does NOT run so the valve stays in the same (Brine) position (all the way down). At the end of the cycle, the motor runs and advances everything back to the starting position (so I get about a 10-second rapid rinse and a 10-second brine refill as the valve is moving). Looks to me like the problem is in the controls somewhere (not the physical valving). I'm assuming I also have a plugged brine line somewhere (maybe in the brine tank; I didn't clean that part) which is why the brine level only goes down about 2 inches in ~50 minutes of my "extended" brine cycle.

    I tried to call Chemical Engineering Corp (the manufacturer, this is a pre-MacClean unit), but all I get is a fax machine. Does the motor / control system use points or contacts that could be bad, and thus causing the "no advance" during steps 3 and 4? I guess I'm wondering if I can try to troubleshoot the motor / control system, or do I just need a whole new control head?

    Thanks to anyone who can share some wisdom on this!!

  • #2
    Re: Intellis Water Softener Woes

    What model is it?

    Comment


    • #3
      Re: Intellis Water Softener Woes

      Replace the unit ...New softners are Much better ...Use less Water and Salt ... 10 Years was a good run ... Dave

      Comment


      • #4
        Re: Intellis Water Softener Woes

        It is a model IS100.

        Comment


        • #5
          Re: Intellis Water Softener Woes

          They are pretty tight with the online information and spec manuals.

          I see the Intellis label is still being sold by Macclean so I would try to contact them there.
          Use the link below.


          http://www.macclean.com/contact/

          Comment


          • #6
            Re: Intellis Water Softener Woes

            Hi I am new to this, but was looking for info on an Intellis. Can you tell me what you ended up doing with your system?

            Comment


            • #7
              Re: Intellis Water Softener Woes

              Get some Iron Out and add a couple tablespoons to the brine tank. Then do back to back regenerations and put the unit back in service. The resin has probably loaded with iron over the years.
              sigpic

              Comment

              Working...
              X