Announcement Announcement Module
Collapse
No announcement yet.
Sump keeps running Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sump keeps running

    Several months ago my sump pump was making a loud noise. I looked and it had emptied the pit so there was no water but it was still running. I played around with the float but it wouldn't stop so I had to unplug it. It seemed hot so I put put some cold water in the pit and left it unplugged for a couple of hours. I plugged it back in and it went on and removed the water then shut off. Everything seemed fine at that point so I forgot about it. Well it just did it again so right now it's sitting unplugged again. I don't know much about this stuff but I'm guessing there could be something wrong with the switch. Any suggestion would be really appreciated. Oh, the pump is only about 1.5 years old.


    Thanks.

  • #2
    55

    how about model #, hp, brand and all that stuff. breid..............

    Comment


    • #3
      Re: Sump keeps running

      is the float a tether style on a cord? is the float hanging up on the pump, discharge pipe or debris keeping it from falling?

      or a solid plastic float on a rod that rides up and down a small rod that lifts a rod arm switch.

      the tether floats tend to be more problematic and typically if it's a 2 cord system/ piggyback cord, you just swap out the float cord. if the float cord is wired into the pump body, then it's time to think about repair or replacement due to cost.

      the lift float assembly is either a bad switch internally in the top of the pump or debris preventing the float from falling all the way back down and shutting the pump.

      running for hours without pumping water has a good chance of burning up the seal on the pump shaft. overheating the oil too.

      rick.
      phoebe it is

      Comment


      • #4
        Re: Sump keeps running

        Here's the pump I have.


        Ridgid SP-330 1/3 HP Submersible Sump Pump


        http://www.ridgid.com/Tools/SP-330-S...p/EN/index.htm


        It is the one that slides on a small rod. There isn't any debris in the pit. I left it unplugged for about an hour last night and then plugged it back in. It emptied the water and stopped. But this is the second time this has happened so something is going on with it.

        Comment


        • #5
          Re: Sump keeps running

          Is there debris stuck in the switch lever arm?

          Comment


          • #6
            Re: Sump keeps running

            Originally posted by Kevin Jones View Post
            Is there debris stuck in the switch lever arm?
            There's nothing stuck in there from what I can tell.

            Comment


            • #7
              Re: Sump keeps running

              What you guys think of these pumps?? They have them at Home Depot and many like them since they have a lifetime warranty and thus feel its a premium pump.

              Then again, my father-in-law bought one and it failed within a couple years and so did my brother and flooded his entire basement within a couple years too

              Comment


              • #8
                Re: Sump keeps running

                In addition the problem I mentioned earlier, and I don't know if this is really a problem but today the pump has been running for only a second and stops but is doing it every minute or so. We did have a lot of rain yesterday but today is bright and sunny.

                Comment


                • #9
                  Re: Sump keeps running

                  oi...my pump is running all the time too and it's mostly just gurgiling.

                  it's this model.

                  This thing is running nearly constantly..while there is water going into the sump the pump is kicking on with maybe 1" of water rise. It never lets the sump fill at all... So the pump constantly keeps the sump empty and makes a heck of a racket..i can post a video if that would be of interest.

                  I have checked to see if the incoming water is hitting the H2o sensor and it does not.

                  Any ideas on how to get this thing to take it easy and let the sump fill a little before draining it so the darn thing isn't constantly running and making so much gurgiling noise..I'm nearly ready to get rid of this thing.


                  Adam

                  Comment


                  • #10
                    Re: Sump keeps running

                    Take the pumps back and warranty them. They are ridgid with a lifetime warranty.
                    DIRTFT

                    Comment


                    • #11
                      Re: Sump keeps running

                      how would you rate the reliability of ridgid pump with the lifetime warranty against perhaps a similar priced zoeller m53 or hydromatic model?

                      Comment


                      • #12
                        Re: Sump keeps running

                        I have that same rigid pump in my house for nine years. No problems yet. Zoeller makes a good pump to but no lifetime warr. that I am aware of.
                        DIRTFT

                        Comment


                        • #13
                          Re: Sump keeps running

                          Next time you encounter your pump running on, give it a kick and see if it shuts off then let us know.

                          Comment


                          • #14
                            Re: Sump keeps running

                            @chewey55; sounds like something is wonky with the switch. take it apart and figure out what and fix it if you are either inerested, cheap, or both. otherwise just replace it.

                            @adam; yours has the capacitance level sensor... these are notorious for twitchy behavior. wipe it clean and it work right again, for a while. bypass it with a float switch if you want it to be reliable.

                            @greekguy; honestly never installed one, or seen one fail. but from the number of folks posting here with problems, I probably never will install one. certainly not one with the capacitance level sensor. zoeller's with floats for my customers. I also like little giant.
                            This is my reminder to myself that no good will ever come from discussing politics or religion with anyone, ever.

                            Comment


                            • #15
                              Re: Sump keeps running

                              All I want to do is buy a new switch for this piece- o- c#@p. Ridgid shows me exactly the part I need 88564. $32.10 which is fine by me. Now the kicker...they will not ship to Canada?????? Hey USPS sends stuff up here every day. I'm willing to pay for post. There happen to be 35 million of us up here and I feel like telling them all to PI$$ on Ridgid sump pumps. Life time warranty LOL

                              Comment

                              Working...
                              X