No announcement yet.

Lost (corrupted) photos in Micro CA-300

  • Filter
  • Time
  • Show
Clear All
new posts

  • Lost (corrupted) photos in Micro CA-300

    First the good news: The files have been recovered.

    Now for the story:
    I performed an inspection and took many photos and one video.

    Each time I pushed the black shutter button the file icon appeared in the center of the screen.

    When I tried to download the files from the SD card in a reader, nothing was there.

    I put the card back in the camera and nothing was there either.

    I called RIGID tech support and was told to turn off the camera and pull the card then turn the camera back on and plug the USB cable back in. When the folders (Drives D & E) opened, there were the files on the camera's internal memory!

    My joy was short-lived however because when I tried to copy the files to the computer there was only an error message.

    I called RIGID back and was informed that the files were corrupted and there was no way to recover them.

    So, since I had photos that would not be easy to replace, I went to Tom's Hardware: Hardware News, Tests and Reviews and learned about "error checking a drive".

    (I don't recommend doing a check with repairs as there were no useful result that I could see.)

    And, I checked the internal memory, found hundreds of errors, and repaired them. Afterwards, the internal memory was BLANK! (Not any corrupt files at all.)

    I went back to Toms hardware and found out about running Recuva - Undelete, Unerase, File and Disk Recovery - Free Download. The recuva program found all my photos and was able to recover all but one photo!

    I suspect that the SD card may not have been fully inserted in the camera. Other than that, I have no idea what happened to corrupt the files.