Announcement

Collapse
No announcement yet.

Not again..

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Not again..

    ...there's a clean out in the front so we rod to the citys tap first, flush the line with a garden hose the flush the toilets and run the bathtub.the w a ter at the clean out from the hose was flowing great but when we flushed the toilet it was barely flowing.so I rod back into the house popped the line open so I camera to the city then camera toward the house .seen a small belly where she was holding a little w ater and went to pull back...tThe damn things stuck ..I mean good too.so I dump about 3 bottles o f detergent to lube it up and start to try to gently twist an pull to break it free .well I lost my freaking footing and slipped a little and pulled the cable..Well I lost picture.ledz still work ..sonde still works so I'm assuming it's gotta be a we ire loose.when you bend the spring it comes on and off..anyone else ever had this problem...o yea sorry ....forgot to mention it's the ridgid full size reel ...old box monitor.

  • #2
    Sent it out earlier just wondering roughly what I'm looking at price wise.

    Comment


    • sewermonster85
      sewermonster85 commented
      Editing a comment
      First time I sent it out it was over 1100$ butI broke the camera head then..

  • #3
    I had the same issue not to long ago. Was roughly $300-400 to repair if I remember right
    Buy cheap, buy twice.

    Comment


    • theplungerman
      theplungerman commented
      Editing a comment
      Ditto me too, same thing

  • #4
    Here was the thread I wrote about it. https://www.ridgidforum.com/forum/me...d-repair-store
    Buy cheap, buy twice.

    Comment


    • #5
      I'm fortunate enough to live within an hour of AJ Coleman so hopefully they're not too busy so I got 3, inspections to do tomorrow I don't feel like putting him off

      Comment

      Working...
      X