Announcement

Collapse
No announcement yet.

CA-350 SD card not reading

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CA-350 SD card not reading

    Hi,

    So I just got my Seesnake microreel with the CA-350 inspection camera delivered to me. After setting it up and turning it on for the first time the screen is showing a symbol that my SD card is not installed. However it is, and it’s installed properly. I tried turning it off and on, taking the SD card out and putting it back in, but to no avail. I tried calling customer service and waited for over half and hour, but no one picked up. I sent a message via the contact center, but no one responded. The camera is useless to me until I resolve this seemingly simple issue, can someone help me? Please??

  • #2
    Have you tried another SD card? That would be first 2nd would be to load the first sd card to a pc then format it.
    Seattle Drain Service

    Comment


    • #3
      Hi Jake72
      The CA-350 should be plug and play for SD card.
      Can you try a factory reset via the menu and as suggested another card.
      What exactly do you see on the screen in the way of an error message?
      Was this bought via our distributor locally, Argentools.
      Regards
      Mike
      Technical Services Manager, Ridgid Europe.

      Comment


      • #4
        Jake72...did you ever resolve this? I'm having the same issue(I think). Top of the screen, it says I have an SD card loaded, however in the center of the screen there's an icon with the letters SD with a red X over it. I've tried two different cards, reformatted the cards, and did a factory reset, but nothing seems to make this go away. The one card has been used successfully in this unit & has pictures on it taken from the unit as well. Any advice/help would be appreciated. Click image for larger version

Name:	IMG_0516.jpg
Views:	3038
Size:	4.03 MB
ID:	746169
        Last edited by Swanny; 08-31-2020, 10:20 AM.

        Comment


        • #5
          When I connect my CA-350 to my computer, I found that I cannot view the pictures or videos taken in "Drive E:". So I did the following from my Windows 10:
          C:> chkdsk E:
          Bad links in lost chain at cluster 44992 corrected.
          Convert lost chains to files (Y/N)? Y
          66043904 bytes in 4486 recoverable files.
          But it did not resolve my problem. So I did the following:
          C:> Format E:
          C:> E:

          I then rebooted my CA-350 twice and the problem is resolved.
          Last edited by Adam.Smith; 04-29-2022, 12:00 PM.

          Comment


          • #6
            If you see the SD picture with a red cross, it is probably because you did not insert the tiny SD card into the SD card adapter before you insert the SD adapter into CA-350.

            Comment


            • #7
              Another thing to check is where the SD card was formatted. If you formatted it using Windows while inserted in your PC it might not be a format that the camera recognizes. So format using the camera if possible or check the manual to see what formats are compatible with your camera.
              "It's a table saw, do you know where your fingers are?" ? Bob D. 2006
              "?ǝɹɐ sɹǝƃuıɟ ɹnoʎ ǝɹǝɥʍ ʍouʞ noʎ op `ʍɐs ǝlqɐʇ ɐ s,ʇı"

              http://cordlessworkshop.net/
              https://www.youtube.com/user/PowerToolInstitute
              https://www.youtube.com/channel/UC1p...qcZKHyrqKhikFA
              ----

              Comment

              Working...
              X