Announcement

Announcement Module
Collapse
No announcement yet.

K380 autofeeder not working ?

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • K380 autofeeder not working ?

    I have recently started to use a K380 I purchased a year or so ago to replace my K375. My problem is with the auto feeder that came with the unit new. it doesn't seem to work real well. the catalog number of the K380 is 87327. is there is way to adjust the auto feed for the smaller cable that came with the k380? the feeder seems to somewhat feed the cable forward a bit, but it doesn't put it back into the drum, weather it is in a drain or not?
    Sent From The StoolBus

    www.appletondrainandsewer.com

    Appleton WI, 54915
    1-920-284-7471

  • #2
    Re: K380 autofeeder not working ?

    I cant understand why one would need one on a 380?
    http://www.all-clear-sewer.com/

    Comment


    • #3
      Re: K380 autofeeder not working ?

      it was the whole kit and for what I paid for it I would expect it to work. I primarily use the feeder to put the cable back into the drum.

      I received a greet deal on a close out model.
      Sent From The StoolBus

      www.appletondrainandsewer.com

      Appleton WI, 54915
      1-920-284-7471

      Comment


      • #4
        Re: K380 autofeeder not working ?

        There is no adjustment that I know of, you just have to make sure you have the lever pushed ALL THE WAY DOWN, if not it doesn't engage. Hopefully someone here knows a way to adjust it to make it work better, because its a pain having to push so hard on the lever every time.
        Water Heater Reviews & Water Heater Information

        Comment

        Working...
        X