Announcement

Announcement Module
Collapse
No announcement yet.

K-60 Troubleshooting

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • K-60 Troubleshooting

    Three days ago while using my K-60sp,the motor shut down.Will not restart nor hum.Thermal overload switch has not worked. Any ideals? All will be welcomed. Thanks Kenneth.
    Kenneth Collier
    Maintenance and Sewer

    P.O. Box 9441
    Jackson, MS 39206
    (601) 613-2678 (Cell)
    drainman881999@yahoo.com

  • #2
    Re: K-60 Troubleshooting

    Have you checked the windings of the motor? What about the switch itself?
    Buy cheap, buy twice.

    Comment


    • #3
      Re: K-60 Troubleshooting

      What troubleshooting have you done? Do you get power to the switch?
      Anyone can tear a man down, few can build one up.

      Comment


      • #4
        Re: K-60 Troubleshooting

        it can be as simple as a bad cord or gfi on the line cord.

        should be pretty easy to diagnose the area of concern.

        does the gfi on the cord light up? yes, next step.

        start with testing for power at the forward/ reverse switch. power yes?

        the motor doesn't have a parts breakdown, time to take it into a motor shop. it could be a bad thermal reset that is burned out?

        i've put my k-60 through hell and back. i've only changed the 2 main bearings on the main shaft.

        no clutch or belt or motor

        rick.
        phoebe it is

        Comment

        Working...
        X