Announcement

Collapse
No announcement yet.

K60 having trouble starting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • K60 having trouble starting

    so my k60 is starting to have this issue where when I turn it on the motor just hums. It does this in forward and reverse. To get it started I’m having to take the handle off and spin the belt by hand to help it along. I’ve tried wd40, greasing all the zurks and loosening and tightening the motor. The clutch jaw and bearings are less than a month old. Is there a simple solution for this?

  • #2
    Scrap pile? I'm just not a big fan of K-60's. AJ Coleman is the place to send it.

    Comment


    • #3
      Easiest way to check it is to remove the belt and see if it starts. If it runs, it’s probably a tight bearing. If not, could be the starting circuit of the motor.

      Rick.
      phoebe it is

      Comment


      • Cable or root
        Cable or root commented
        Editing a comment
        Turned out to be the motor, I was able to swap the motor out with an old one we had lying around. Thanks rick

    • #4
      Originally posted by Cable or root View Post
      so my k60 is starting to have this issue where when I turn it on the motor just hums. It does this in forward and reverse. To get it started I’m having to take the handle off and spin the belt by hand to help it along. I’ve tried wd40, greasing all the zurks and loosening and tightening the motor. The clutch jaw and bearings are less than a month old. Is there a simple solution for this?


      I've been running all my 7/8" and 5/8" sectional cables from a drill.

      Comment


      • Cable or root
        Cable or root commented
        Editing a comment
        I love the drill for 5/8 cables and still use it now. Not sure how the boss man would feel about me using a drill to run 15’ sections of 7/8 cable. Chances are he wouldn’t appreciate it very much.

      • AssTyme
        AssTyme commented
        Editing a comment
        Get the 5' sections from DCD.
    Working...
    X