Announcement

Collapse
No announcement yet.

Hey Josh I have a NEW problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Re: Hey Josh I have a NEW problem

    If this GAP was filled it would never fall off. The end is smaller then the inside of the tool so it`s a very loose fit and needs more weld. I will fix this one and post a picture after it`s welded and we`ll see how much longer it is till I have to buy another one.
    http://www.all-clear-sewer.com/

    Comment


    • #32
      Re: Hey Josh I have a NEW problem

      Ok.. just to clear this up... your latest pictures were of an auger right? not the cable? Cause that sure has heck doesnt look like the ends of the cable.

      We really are looking into the weld issue at the base level of production. Eric is having them take some pictures of cables coming off the production line. They are also trying a few new things to improve the welds. I hope to have some pictures up here some time soon. My plan is to stick some before and after pictures of the welds coming off the line to see what comes of the effort (may take more than a day so be patient ).

      Your best bet on the broken cable is probably to call tech services directly at 1-800-519-3456 I have already informed the Head of tech services about the issues you have run into. He wants to have you send in the end of the cable that broke so we can inspect how the weld broke. If you would like to talk to him ask to talk to John when you call in.

      As far as the foot pedal, it looks to me like there is a big gouge out of the side of that pedal??? Are you sure the pedal wasnt damaged or sheered by something when transporting??? A stress crack usually appears as a line that closes itself back up when the pedal isnt compressed.

      Josh

      Comment


      • #33
        Re: Hey Josh I have a NEW problem

        Just got a little more info on the Retrieval Auger welds. Production say that that is the only coupler that still gets manual welds. I actually have one sitting in my office now. The rest of our line screws into the attatchement then is machine welded. They are going to rework the auger attatchment process and send before and after pics on that too. I will post when I get them. They said a couple weeks.

        Josh

        Comment


        • #34
          Re: Hey Josh I have a NEW problem

          On the foot switches they start out as a little crack then when you take your hand and push down on the crack it gets larger. No it`s not a gouge or a hole from something poking it. It`s a crack from the rubber not flexing enough. I could send them in if you`d like and you can push on them and watch em get larger. Like I said, the rubber is not soft enough and it just cracks out. The two foot switches cracked out in the same spot. The one I just broke, I bought 11/17/06 for $35.33

          As far as the weld goes, if you read the post and look at the box pictured you will see that it was a "Retrieving Auger" I got one 11/29/06 and lost it, so bought this one 3 weeks a go and broke it off yesterday.

          Now the Cables are another story, Like I said; they bend up very easily now that the New inner core cable does NOT support the outer cable. It`s very loose inside the outer cable and it`s a few feet short to support the cable ends thus lets em bend up and not feed right. It`s like not having any inner core at all! Trust me, I work this thing every day and Ridgid is welcome to come spend a day with me and see all of what I`m talking about. I use to be able to have 125` loaded up but now with this new inner core it bends up and wont feed in or out when loaded up with 125` of the new 3/4 inner core cable. "Yes" I rewelded all my new 3/4 inner core cables but I still have that 3 month old 25` 3/4 inner core cable laying out back that is all bent to **** and with the end broken off I`d be more then happy to send it in if you would like?
          http://www.all-clear-sewer.com/

          Comment


          • #35
            Re: Hey Josh I have a NEW problem

            If you would like to return sample cable for warranty inspection, please return Attn: John

            The RIDGID Factory Service Center
            321 Sumner Street
            Elyria, Ohio 44035

            Please add contact information and I will give you a call.

            Comment


            • #36
              Re: Hey Josh I have a NEW problem

              BTW All Clear... this is an official response from John from Tech Services in case you were wondering. I dragged him in here I would recommend including the foot pedal as well as long as you are shipping here.

              Originally posted by ToolMan View Post
              If you would like to return sample cable for warranty inspection, please return Attn: John

              The RIDGID Factory Service Center
              321 Sumner Street
              Elyria, Ohio 44035

              Please add contact information and I will give you a call.

              Comment


              • #37
                Re: Hey Josh I have a NEW problem

                i too thought it was a picture of the cable. now that you showed the whole thing, i can see the issue. all the torque is on the welds, since there is no thread on the coupling. why

                a retriever has to be the strongest tool since you need to bring it and the lost cable back.

                i very rarely use my retrievers i guess that i rarely loose cables or ends

                i will check very close to see the connection and welds on my retrievers. i think that i have 3 or 4.

                still can't believe there is no thread on the connector to hold the cable

                rick.
                phoebe it is

                Comment


                • #38
                  Re: Hey Josh I have a NEW problem

                  Nor I... this is one that slipped by without being changed. it is being reworked as we speak.. all because of the forum. I'll post before and after pics as soon as I get them from production.

                  Josh

                  Originally posted by PLUMBER RICK View Post
                  i too thought it was a picture of the cable. now that you showed the whole thing, i can see the issue. all the torque is on the welds, since there is no thread on the coupling. why

                  a retriever has to be the strongest tool since you need to bring it and the lost cable back.

                  i very rarely use my retrievers i guess that i rarely loose cables or ends

                  i will check very close to see the connection and welds on my retrievers. i think that i have 3 or 4.

                  still can't believe there is no thread on the connector to hold the cable

                  rick.

                  Comment


                  • #39
                    Re: Hey Josh I have a NEW problem

                    Originally posted by Josh View Post
                    BTW All Clear... this is an official response from John from Tech Services in case you were wondering. I dragged him in here I would recommend including the foot pedal as well as long as you are shipping here.
                    I am sending a cut-off off my New 100` inner core and a cut-off off a 3 year old 100` inner core. I want you to give em the bend test. Place them in your hands and bend then you will see that the new cable is not near as strong as the old cable. I am also sending that 3 month old 25` cable that is all bent up with an end broken off along with the 2 foot switches.
                    I already rewelded the retriever as I needed it last night so it wont be coming but you already know the problem with them so no big deal there.
                    I`m boxing it all up and it will be on it`s way today
                    Thanks Josh
                    Last edited by All Clear Sewer; 03-02-2007, 10:13 AM.
                    http://www.all-clear-sewer.com/

                    Comment


                    • #40
                      Re: Hey Josh I have a NEW problem

                      allclear, i knew about the cable innercore years ago. i found out the hard way too. you get used to the torque the cable can withstand and all of a sudden the cable ain't what it use to be.

                      i switched to a different company sorry ridgid.

                      bring back the old innercore. it was bullet proof and that's what the big boys need we were use to the better cable and innercore. we don't like the replacement.

                      p.s. i'm still sitting on 1- 3/4'' x 100' old style innercore, brand new.

                      what's that worth priceless

                      rick.
                      phoebe it is

                      Comment


                      • #41
                        Re: Hey Josh I have a NEW problem

                        I hear ya Plumber Rick

                        Ok, It`s off and on it`s way as I just got back from droping it off at FedX.
                        It`s even in the Ridgid Cable Box that the new 100` came in so you will have the stock number and all

                        How ever I forgot to give ya my Phone number so here ya go 620-664-XXXX (last 4 digits removed by admin)
                        Thats my cell number so you will only get "me" when you call
                        Steve
                        Last edited by Josh; 03-02-2007, 12:17 PM.
                        http://www.all-clear-sewer.com/

                        Comment


                        • #42
                          Re: Hey Josh I have a NEW problem

                          Did you all get the package?
                          http://www.all-clear-sewer.com/

                          Comment


                          • #43
                            Re: Hey Josh I have a NEW problem

                            I'll check tomorrow with John. Should be here by now I would think.

                            Josh

                            Comment

                            Working...
                            X