Announcement Announcement Module
Collapse
No announcement yet.
clogged sewer or faulty sump pump? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • clogged sewer or faulty sump pump?

    I have a 7 yr. old house. For the first 6 years I had no water in the basement. During the past year, I have had three episodes of water. After the second one a month ago, I had a new RIGID 1/2 hp sump pump put in. During he past two rains, I have noticed the sump pump works fine for 15-20 minutes, then the water level rises quickly. After the rain stops, the pump runs continuously for hours and the water level doesn't drop much. I even unplugged the pump and the water level didnt rise. Also, I have four window wells with a drain in each. During the last rain, the water looked like it was not going down the drains. any advise?
    R.M.

  • #2
    avon bob, it sounds like your pump is lacking a 3/16'' vent hole below the check valve. this is causing an air lock situation. basically the pump has an air pocket trapped in it. the hole will allow the air to vent. make sure you drill it at approx. the level of the top of the pump. also the hole will discharge some water when the pump runs. make sure it's pointed back into the pit.
    95% of these symptoms are caused by what i noted.

    rick.

    Comment


    • #3
      Hello,

      Avon Bob has sent you the following message through RIDGID Shoptalk
      Forums:
      --------------------
      Thanks for your response. We did check that first and it was OK. It
      turns out that the developer never connected my storm drain to the storm
      sewer. The water was just emptying into the ground and eventually
      blocked up with leaves and other debris. The city came yesterday and
      connected it. thanks again.

      well bob, that's the 5% i didn't account for.
      glad you got it figured out and fixed.

      rick.

      Comment


      • #4
        Could not having a vent hole cause the pump to NOT spin the impeller? I installed the same pump with the check valve at the base of the pump with a flex hose draining the water into a basin sink next to the pit until I can get regular PVC hooked up.

        The pump will operate a couple times and then it will turn on and shut off almost immediately without seemingly turning the impeller to pump the water out. I have to remove the pump from the bucket and shake and/or tap it on the floor to get it to operate properly again.

        Thanks, +Petrose
        The Lord gives and the Lord takes away. Blessed be the name of the Lord.

        Comment


        • #5
          petrose, if the impeller isn't spinning then you have a problem with the pump. missing a vent hole will cause the pump to run, including the impeller to spin. the pump will not pump out water due to an air pocket trapped between the impeller and check valve.
          sounds like what you described is a bad pump.

          rick.

          Comment


          • #6
            Thanks, Rick. I'll have to verify the warrantee which I'm pretty sure I sent in, but can't specifically remember, and I'll plan on getting it hooked up according to what you posted above and from diagrams I've seen on thses sites.

            Thanks again, +Petrose
            The Lord gives and the Lord takes away. Blessed be the name of the Lord.

            Comment

            Working...
            X