Announcement Announcement Module
Collapse
No announcement yet.
Ridid Planer TP1300L Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ridid Planer TP1300L

    So, two weeks ago I used my planer to plane some pine stock down from 3/4" to 5/8". No big deal, worked fine.

    I tried to use my planer the other day and it does *nothing*. Doesn't turn on at all. I verified the outlet / circuit is fine by running my router and then my jointer on the same plug. I've tried the little cheesy reset button on the front of the motor. Absolutely nothing happens when I turn the planer on.

    Has anyone had a similar experience with the motor ceasing to operate or something else occuring? What was the solution?

    My nearest Ridgid service center is over an hour away, so I'm hoping there is some secret little button, or fuse, or something that I can get this machine back up and running.

    This machine has seen probably a grand total of 100 BF of pine or cedar, and about 15 LF of 2.5" wide maple. That's it... not a lot of heavy use, so I'm skeptical the brushes might be the issue... but perhaps...

    Thanks in advance for any help.

  • #2
    Re: Ridid Planer TP1300L

    Those cheesy reset buttons can take a bunch more pressure than you would expect to reset. Try pulling the safety clip from the on off switch and make sure it is not broken and seated correctly. The only other thing I can suggest is that you unplug it and spin the motor by hand, if there is a bit of wood holding the brushes off the armature that should dislodge it, you could also remove the brushes to accomplish the same thing

    Comment


    • #3
      Re: Ridid Planer TP1300L

      Thanks a bunch. I'll try these suggestions tonight! I checked the safety key, but I will recheck, just to be sure.

      I'm not sure how I'd spin the motor by hand. The rollers are the only accessible part (I'm not really willing to try to spin the blade by hand) and you can't turn those manually. I've tried, when they first needed a good cleaning.

      Comment


      • #4
        Re: Ridid Planer TP1300L

        you need to turn the blade housing by hand to change the blades and this will turn the motor and although not really noticeable the feed rolls. It should be safe enough to spin the motor via the blade housing but pulling the brushes is just about as easy. One other thought is that you may have a dead coil in the motor, pulling the brushes may not get it to spin but if you move the motor and it starts you may have a dead winding.

        Comment

        Working...
        X