Announcement

Collapse
No announcement yet.

Ebox problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Re: Ebox problems

    canucksartech, see my response in post #9 of this thread. You'll need to reset your password in order to get into your new "Dashboard"(stupid name). As I stated in my response, you can use your old password if you like. Go to www.ridgid.com and click on the Lifetime Service Agreement prompt at the bottom of the page to access the Dashboard(stupid name).

    My Dashboard has been fully updated and all the information in it now is correct. HTH.
    ================================================== ====
    ~~Don't worry about old age; it doesn't last that long.

    Comment


    • #32
      Re: Ebox problems

      and now my ebox reflects 3 year warranties for tools which, before the "dashboard improvement", reflected lifetime service agreement. i can only hope the guy that was responsible for this ebox fiasco is kept as far away fromt the actual tool side of Ridgid as is humanly possible.
      there's a solution to every problem.....you just have to be willing to find it.

      Comment


      • #33
        Re: Ebox problems

        Originally posted by BadgerDave View Post
        canucksartech, see my response in post #9 of this thread. You'll need to reset your password in order to get into your new "Dashboard"(stupid name). As I stated in my response, you can use your old password if you like. Go to www.ridgid.com and click on the Lifetime Service Agreement prompt at the bottom of the page to access the Dashboard(stupid name).

        My Dashboard has been fully updated and all the information in it now is correct. HTH.
        I did all of that BadgerDave. No luck, and definitely no joy. I've requested a password reset, and I'm still waiting for that e-mail to arrive. Man, if I have to re-register the 4 or 5 thousand dollars worth of tools, and whip out 14 or 15 different sets of receipts/photocopies/cards/etc. from everything, am I ever gonna be something pissed!!!! I'll turn into one angry beaver!!!!

        Comment


        • #34
          Re: Ebox problems

          OOOOOOKKKKKAAAAAAAAYYYYYYYY!!!!!!!!!!! DUDE, THIS SUCKS!

          ProBrand, Josh - this HAS to get sorted out, and soon!

          I've finally got into my eBox...sorry, my "Dashboard" (yes, it sucks - doesn't show nearly as much detail as the previous eBox, and doesn't group things according to category. The eBox format was perfect!).

          Well, I've just gone through every listed item that was on there (I don't think I was missing anything), but there are some major problems. Out of the 72 items that are showing that I have listed on there (batteries and chargers included), there are only about 30 with the LLSA showing - they were all showing them before, save for one new drill kit that was still waiting on the processing. Also, there's tons of little glitches - like the fact that a "Compact Battery 1" is showing the serial number for my pneumatic stapler, and that stapler is listed somewhere else, but with no serial number or other details showing.

          What the heck is going on here??!! I swear to God, if we have to re-register this stuff like CS is telling us, Ridgid is going to have some major problems....

          Comment


          • #35
            Re: Ebox problems

            As of right now, I now only have 6 items showing in my Dashboard. I only have the various stuff listed for the 12 volt lithium screwdriver, and then the 3000 psi pressure washer. Is there an update coming from Ridgid on this issue??

            Comment


            • #36
              Re: Ebox problems

              Have you clicked on the "view all products" prompt? I don't understand why they feel it's necessary to show only some of the registered products on the main page of the Dashboard and then have a second page that list all of tools that are registered, it seems like unnecessary confusion to me.
              ================================================== ====
              ~~Don't worry about old age; it doesn't last that long.

              Comment


              • #37
                Re: Ebox problems

                Originally posted by BadgerDave View Post
                Have you clicked on the "view all products" prompt? I don't understand why they feel it's necessary to show only some of the registered products on the main page of the Dashboard and then have a second page that list all of tools that are registered, it seems like unnecessary confusion to me.
                Yep, did that, that wasn't the issue. It is however all back there though???

                The other funny thing is, if someone isn't reading this thread, and doesn't know of the changes, where is the note on the webpage to let them know where they go? If you go through the webpage under "Support", it still has the spot to click that says "Go to eBox", which takes you to the blank page, with the redirect to register a tool. So where is the logo/tab that says "Go to Dashboard (and here's what that is, by the way....)". The logo on the main page that ProBrand said we need to use says "Register Now..." with the LLSA logo. That tells someone uninformed that it's to register a new tool, not check out your already registered stuff. That's my thoughts anyways.

                Comment


                • #38
                  Re: Ebox problems

                  week three and my ebox is still undeciferable. product descriptions are missing and it is stupid to have to click on a dashboard item to get the name of the tool being accessed. or am i the only one who doesn't know what an R8452B is? even when i click on a dashboard item, there's no description for things like an R81030B. but what makes it really interesting is that when R81030B is plugged into the search field under products, this is the message that's returned: "Your search resulted in no direct matches." way to go ridgid. this is so tedious!
                  there's a solution to every problem.....you just have to be willing to find it.

                  Comment


                  • #39
                    Re: Ebox problems

                    Glad that I read this thread.. was about to ring up CS to complain. After I requested for p/w (yeah, as if I have lost it), I can log back in and everything is there...

                    the only weird thing is that my ROS has duplicated entries.. othwewise, all is good.

                    Comment


                    • #40
                      Re: Ebox problems

                      week three and my ebox is still undeciferable. product descriptions are missing and it is stupid to have to click on a dashboard item to get the name of the tool being accessed. or am i the only one who doesn't know what an R8452B is? even when i click on a dashboard item, there's no description for things like an R81030B. but what makes it really interesting is that when R81030B is plugged into the search field under products, this is the message that's returned: "Your search resulted in no direct matches." way to go ridgid. this is so tedious!
                      there's a solution to every problem.....you just have to be willing to find it.

                      Comment


                      • #41
                        Re: Ebox problems

                        Almost as tedious as a double post!!

                        Comment


                        • #42
                          Re: Ebox problems

                          Okay, it's been another stretch of time here, and nothing really resolved. I called CS, and was transferred over to the Promotions department, and spoke with Jessica. She helped me out, and went through my Dashboard/eBox with me. She saw were certain things were listed as only having the 3 year warranty, and others with the LLSA (IE - I had one drill kit listed in there where the batteries and charger were showing 3 years, but the drill was showing LLSA, all with the same registration date, and when all were long ago showing the LLSA).

                          (Jessica is who I dealt with; an excellent rep, very good at sorting through the issues and helping out - Jessica you deserve a raise!) She explained to me that this whole changeover hasn't even really been explained to them very good either, that it's still being worked on by the team responsible for it. I explained to her our frustrations as talked about on this forum (no notice of changeover, not as user-friendly of a system as the eBox, warranty/LLSA registration glitches, etc.). She elaborated to me that they are aware of these issues, they've received a ton of phone calls, and it is being worked on, they just don't know for how much longer. She did tell me that if other members call in, we should request to speak to the Promotions department. She said that what some members have been told by the main Customer Service reps (that we'd need to re-send in all of our registration documentation) is incorrect, that at the present time we shouldn't need to do this, and we're best to just hold and wait for the changes to be worked out. She helped me in getting a few items changed back to the LLSA, and said she/I would keep an eye on the rest.

                          I explained to her that a lot of the frustration from us customers is due to no word from Ridgid/TTI/OWT on this whole kerfluffle, and she said that they did understand that, that we should have been given a notice of the pending changes, and that we should be getting told something as things roll along here (Ridgid, you there?????)

                          So, basically, it'll take some patience from us for another few weeks as they get this resolved. But just keep an eye on our Dashboards, and then go from there.

                          Comment


                          • #43
                            Re: Ebox problems

                            Anybody out there been denied free repair service of a previously LLSA registered tool since this whole Dashboard(stupid name) switchover has been going on? Unless people are being denied free repair service or batteries, I doubt if any of this current situation is anything more than a technical problem with the website. A mole hill will never be a mountain.
                            ================================================== ====
                            ~~Don't worry about old age; it doesn't last that long.

                            Comment


                            • #44
                              Re: Ebox problems

                              after finally being able to print out the contents of my ebox, and the eboxes of my two sons, i can now start slogging up the mighty hill of corrections with ridgid to 1) get warranties to show, either three years or lsa, because no warranty info is input for tools registered 8 months ago, 2)remove non existent tools from all three of our eboxes and 3) add in to our respective eboxes tools that were previously listed correctly and are now missing. this is a terrible mess in the dashboard system. one can only imagine how much time this will take. badger dave said it best, "it was working just fine, so they broke it". hey ridgid, really, really bad performance on this one.
                              there's a solution to every problem.....you just have to be willing to find it.

                              Comment


                              • #45
                                Re: Ebox problems

                                update.... now when i try to register my new tools online i get a response that say email already taken i know its taken its mine. i cant register new tools or contact customer service via the dashboard i can log in but thats all.
                                When i called customer service they said best not to even register products online just mail stuff in. LOL Ive mailed stuff in way back in april still no response Is there anybody in charge i can speak to about this problem cutomer service was nice but not much help. The LSA was a big reason for me to purchase from ridgid but this is crazy

                                Comment

                                Working...
                                X