Announcement Announcement Module
Collapse
No announcement yet.
TS2400 Motor Starts then Stops Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • TS2400 Motor Starts then Stops

    I have a TS2400 that will power up, but the motor stops just as it comes up to speed. I suspect the circuit board that is part of the switch assembly. I got the saw from a friend, and I don't have paperwork. It has been well taken care of.

    I have pulled the motor and the internals look ok. The brushes are fine. I removed the gearbox and ran it without any load - still does the same thing. I have tried multiple circuits - power feed is fine.

    Any ideas?


    - Jason

  • #2
    Re: TS2400 Motor Starts then Stops

    I would bet it is the soft start board as well.
    You could just feed the motor with 120 to make sure.
    Not sure if the board is a sealed black box or if you can see the components. If you can see the components borrow an oscilloscope and look at the triac to determine what is happening, you should be able to shoot it easily with a scope

    Comment


    • #3
      Re: TS2400 Motor Starts then Stops

      My friend is looking for the paperwork, but it is doubtful. If he can't find it, I'll jumper the board and see if the motor runs. The board is not sealed. I can take it to work and put it on the scope. I don't have much experience with universal motors, but I imagine that there is some type of PWM signal being sent to the motor via the board. There is no nameplate or specifications listed on the motor housing.

      - Jason

      Comment


      • #4
        Re: TS2400 Motor Starts then Stops

        Its just an over sized vacuum cleaner motor. I would expect a timed PWM for the soft start and then solid gate. I doubt there is any sort of feedback circuit (too expensive). Sounds like once the soft start PWM circuit times out it drops the gate instead of holding it

        Comment


        • #5
          Re: TS2400 Motor Starts then Stops

          Do you know where I can get a wiring diagram for the circuit and motor for this saw?

          I suppose I could just run it without the soft start - might trip the breaker occasionally. If I can find a bad component on the board, I may be able to repair the board instead of buying a new one.

          - Jason

          Comment


          • #6
            Re: TS2400 Motor Starts then Stops

            I would call Ridgid (1-800-474-3443) and ask but I would not hold my breath since the board is a P/N, as you know the skills of a good trouble shooter are mostly wasted these days as the mentality has shifted to 'swap til you drop' from board level component replacement. Doubt there are too many components on there, bet you can figure it out by xref the P/N's on the components. You could also look up a local repair shop and see what they have

            Comment


            • #7
              Re: TS2400 Motor Starts then Stops

              I'm in the market for a TS2400, so I don't know about the specifics of the TS 2400, but it sounds like when the soft start gets done with its job the relay flips over to an open circuit.
              Goofy wiring?
              Look for loose connections between the soft start and the motor or a broken wire.
              I'm in construction. When something like this doesn't work on a consistent basis a new tool is usually bought. I've resuscitated countless tools by simply looking for the obvious where no one else has looked.
              Also....smell the motor. If it smell burnt or that electrical burnt smell....bad news.

              Comment

              Working...
              X