Announcement

Announcement Module
Collapse
No announcement yet.

Ridgid R175RNA - Bump firing not working

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ridgid R175RNA - Bump firing not working

    Anyone have an idea on what would cause the bump fire mode to not work? I purchased the gun used, so no LSA. Any advice is appreciated.

    I've priced the trigger, but not sure if I am looking to replace the right part...

  • #2
    Re: Ridgid R175RNA - Bump firing not working

    Lee,

    Welcome to the Ridgid forum!

    Are you sure you have the trigger set in the proper position for "bump" firing?

    Looking at the trigger from the left side, there's an orange diamond shape... it has a single-nail emboss on one end and a triple-nail emboss on the other. For "bump" firing, you press in on the orange button on the right side of the trigger (which pushes the left diamon-shape out of its seated position) and rotate the diamond shape (left side of trigger) so the triple-nail end it up, toward the indicator arrow.

    I hope that is the reason it doesn't work for you,

    CWS

    Comment


    • #3
      Re: Ridgid R175RNA - Bump firing not working

      Yea, I have the trigger in the bump position (3 nails on the switch setting). A friend of mine has the exact same nailer and his works on the same setting I've tried.

      Comment


      • #4
        Re: Ridgid R175RNA - Bump firing not working

        I have the same problem,if I hold down the gun an the deck it hisses and then fires,I dont mind the single fire mode,better acuracy/nail placement.If you got yours fixed let us know,thanks

        Comment

        Working...
        X