Announcement Announcement Module
Collapse
No announcement yet.
pressure washer 80746 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • pressure washer 80746

    hi all,
    I am unable to get the air out of the lines...what could be the problem?

    with the engine off and the hose connected, water will not flow through the pump

    any ideas...please

    goatee

  • #2
    Re: pressure washer 80746

    Well is the water on when you try this? Seriously, are you squeezing the wand trigger when doing this? Later!

    Comment


    • #3
      Re: pressure washer 80746

      yes, the water is on , in fact I turn my well pump up to 70 psi and the garden hose was starting to expand!

      and yes I was pulling the trigger.

      there looks like some kind of valve on the pump (brass housing) just before the water exits to the high pressure hose. I was thinking that maybe this was set wrong at the factory?

      goatee

      Comment


      • #4
        Re: pressure washer 80746

        I would make sure of the following:

        1. If I recall correctly there was a plastic insert on the water faucet connection to protect it during shipment, this must be removed
        2. Make sure all connections are connected... quick connects are actually snapped in. From the exit side of pump all the way thru the wand.

        If you have the water turned on, and all the connections made, when you pull the trigger you should have water flowing out the end of the wand. It may take several seconds if there is air in the line.

        Comment


        • #5
          Re: pressure washer 80746

          Try just hooking the water hose up and leave the high pressure hose disconnected. Then try running the water through the pump.
          There could be some junk in the hose??

          Comment

          Working...
          X