Announcement

Announcement Module
Collapse
No announcement yet.

Can't mount spindles on Rigid oscillating spindle/belt sander

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't mount spindles on Rigid oscillating spindle/belt sander

    I purchased my Rigid oscillating spindle/belt sander several years ago and found it impossible to mount the rubber spindles on the shaft. I started using the machine entirely in belt sander mode and never got around to addressing the spindle mounting issue. Recently I decided to revisit the problem and tried using baby powder on the shaft to reduce the friction without success. The sleeves fit on the spindles just fine but no way can I get the rubber spindle onto the shaft. Has anyone else had this problem?

  • #2
    Re: Can't mount spindles on Rigid oscillating spindle/belt sander

    without photos it's very difficult to provide any assistance.
    The smallest sanding sleeve should simply slide onto the shaft.
    It may have a build up of debris and baby powder does not help!

    Clean the shaft carefully and then try the various rubber spindles without sanding sleeves
    you may have the wrong sanding sleeve sizes. Again the 1/2" sleeve should simply slide on.

    How about using a caliper to measure diameters etc.

    Do report back

    Cactus Man

    Comment


    • #3
      Re: Can't mount spindles on Rigid oscillating spindle/belt sander

      After trying each of the rubber spindles, I find that the two smallest fit with no problem. It is the two largest which don't fit. Apparently when I first encountered the problem I tried the two largest and when they didn't fit I gave up. One of the attached photos shows the largest spindle pushed down to the point where it has to be forced pretty hard to go further. I did that once. It didn't go down much farther and it was very difficult to remove.
      Before this fit test I thoroughly vacuum cleaned the sander and shaft. I also wiped out the insides of the two large rubber spindles with a dry paper towel. I also tried chamfering one end of the hole in the largest with a knife to make sure there wasn't some small rubber lip folding over to interfere.
      Attached Files

      Comment


      • #4
        Re: Can't mount spindles on Rigid oscillating spindle/belt sander

        I just went out to my work shop to look at my Ridgid EB44241 oscillating edge belt spindle sander.

        I measured the shaft and it's 1/2"
        Affixing the smallest 1/2" sanding drum is slightly snug. About half way down I had to apply a small amount
        of pressure to fully seat it correctly. I tried a NEW and USED 1/2" sanding drum and it did not make any
        difference as to how much pressure I used to install them.

        I then went to my 2" sanding drum and sanding sleeve. The sanding drum opening is 1/2" +/- a hair! I tried not to
        force the caliper when measuring the opening.
        The drum slid on easily with or without the sanding sleeve.

        I repeated this drill with the other sanding drum/sleeve sizes....nothing changed and they all slid in well!

        I know the manual discusses using talcum powder as a lubricant if the drum won't slide in easily
        but I really discourage this. Also DO NUT cut or trim the sanding drums then they will definitely fail!

        Some possible solutions:

        I suggest you take a 1/2" dowel rod [preferably oak] and run the sanding drums up and down to
        loosen them up slightly.

        I suggest you may want to take some 400 or 500 grit wet/dry sand paper and rub the motor shaft
        the entire length 360 degrees 2 or 3 times. Do this with damp sandpaper. Then really dry the shaft and try the 1/2" sanding sleeve to determine
        if there is a change. Then try the 2" drum without the sanding sleeve. Perhaps you have a slight burr on the shaft?

        The sanding drums have some flexibility to them so they should slide on with reasonable [light] force; and slide off
        easily as well.

        If you still have the challenge then contact customer service for LSA warranty replacement of the sanding drums.

        My unit is 2006 vintage and has never had any problems wow how time flies by huh!

        Cactus Man
        Last edited by cactusman; 05-27-2011, 10:38 AM. Reason: spelling error

        Comment

        Working...
        X