Announcement

Collapse
No announcement yet.

Shop vac will blow but won't suck

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • masterbeavis
    replied
    Re: Shop vac will blow but won't suck

    Hehehehehe, I could not resist...






    Last edited by masterbeavis; 09-28-2011, 08:19 PM.

    Leave a comment:


  • BHD
    replied
    Re: Shop vac will blow but won't suck

    I was going to say the seal your getting is probably not good, on the lid to the tank, or how ever it is, If you put your hand over the sucking hole and press on the lid or twist see if it pops down and it may be warped plastic or some thing, or some junk holding up a small section and not letting it seal,

    Leave a comment:


  • Jennifer53
    replied
    Re: Shop vac will blow but won't suck

    Thank you for the suggestions! I fussed and fidgeted with it some more and now it's working - I think originally it wasn't getting a tight enough seal when closed. Whatever it was, it's working now and hopefully we'll have a dry basement by morning!
    Thanks again!!

    Leave a comment:


  • PLUMBER RICK
    replied
    Re: Shop vac will blow but won't suck

    for the vac to blow air out of the outlet, the vac has to be sucking in air.

    you've already made sure the float is not in the up/ float position. that only really applies to liquids. have you determined that the hose is not plugged at either end?

    the filter is clean?

    are you sure that the vac is blowing from the outlet port or just the motor fan blowing air?

    a vacuum that doesn't suck and only blows, sucks

    rick.

    Leave a comment:


  • Alphacowboy
    replied
    Re: Shop vac will blow but won't suck

    There is no suction at the inlet of the vacuum, but there is air blowing at the outlet?

    Leave a comment:


  • Jennifer53
    started a topic Shop vac will blow but won't suck

    Shop vac will blow but won't suck

    Any help would be great!! No, the filter isn't on, the float moves freely, I've taken the whole thing apart and nothing is blocking anything or clogged. Can I try anything else - or should I just call Noah at this point?! Thanks, all!!
Working...
X