Announcement Announcement Module
Collapse
No announcement yet.
New RD8000 Starting Problems Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Re: New RD8000 Starting Problems

    Originally posted by SkoolOfHardKnox View Post
    Thank you very much for the responses. Much appreciated.

    I've checked and rechecked going over again as instructed in the manual and the advice given here. The carburetor bowl is working and there is clean fuel in it. Tank's full, oil levels fine. The spark plug is clean and there is also spark. I noticed that when I sprayed starting fluid in the carburetor the engine will start/turn somewhat with white smoke out the exhaust, but will quit soon thereafter. It does that each time I use the starting fluid. I don't want to give up just yet. If not, then as Doctordeere said:
    Clean fuel in carb bowl, cranks and spark plug is clean? Plug should be wet with fuel if cranking and not starting.

    Comment


    • #32
      Re: New RD8000 Starting Problems

      Well, after checking out the fuel flow and carburetor bowl again, fuel is flowing and also in the bowl. Spark plug is "clean" though not bone dry out of the box. There is "oil residue" on the Center and Ground Electrode of the spark plug. Also after some of the fuel spurt from the hose and whatnot, the filter housing caught fire for about 7 seconds or so after I tried starting the generator again before being snuffed out. That kinda sorta startled me! Good think I didn't blow myself up. Going to have to try more of ya'lls advice tomorrow. Thanks once again everyone!

      Comment


      • #33
        Re: New RD8000 Starting Problems

        Here's some shots before the fire I started.







        Now this one's baffling to me. The "connector" pictured at the 3 o'clock position isn't connected to anything. Is this "normal"?

        Comment


        • #34
          Re: New RD8000 Starting Problems

          I think Id bring it back to HD like a previous poster said. Make them start it up for you, or just demand a replacement.

          Ive had mine for 3 years now and it starts within 5 or 6 seconds of cranking, even after being run out of fuel and sitting for a while.

          And for some reason I think I remember the same yellow/yellow-red wire being disconnected on mine too. Not quite sure what its for, I tried putting a multimeter on it to see if it gets/loses voltage based on ignition switch position but I dont remember it doing anything.

          Comment


          • #35
            Re: New RD8000 Starting Problems

            Thanks for all the feedback! Looks like I'll be exchanging this generator. Man alive! Now got to empty the fuel tank and load this beast up once again!

            Comment


            • #36
              Re: New RD8000 Starting Problems

              This evening I exchanged this particular generator for another one at the local HD. They said they don't have any in stock (according to their computer system) but I said not true! In fact I saw more than a few boxes on the floor throughout the store before approaching the HD CS Returns, but that's another story. Anyway, as-soon-as I brought it home and assembled it and putting in fresh/new lubricant and Union 76's 92 Octane Gasoline, this RIDGID RD8000 started straightaway! Again, thanks for all the input RIDGID Guys!

              Comment


              • #37
                Re: New RD8000 Starting Problems

                Okay, I decided to see how this newly exchanged RIDGID RD8000 will do this afternoon. Check this out and see what gives?



                Now it's acting up like the first. What's wrong this time around? Any suggestions? Thanks again in advance!

                Comment


                • #38
                  Re: New RD8000 Starting Problems

                  At 34 seconds the rod going to the carb moves to the right on it's own. It shuts down immediately when this happens. Not familiar with this engine or carb at all. Just an observation.

                  Comment


                  • #39
                    Re: New RD8000 Starting Problems

                    Originally posted by BobsPlumbing View Post
                    At 34 seconds the rod going to the carb moves to the right on it's own. It shuts down immediately when this happens. Not familiar with this engine or carb at all. Just an observation.
                    Thanks. I'm just frustrated here that's all. Hope this one's not a "dud" whereupon I'll have to do a return/exchange.

                    Comment


                    • #40
                      Re: New RD8000 Starting Problems

                      I would chase that rod down to where it goes. Then I would maybe try holding it to the left (towards the carb) when cranking.

                      DISCLAIMER: I know nothing of this generator and anything/everything you do is at your own risk.

                      Comment


                      • #41
                        Re: New RD8000 Starting Problems

                        Originally posted by BobsPlumbing View Post
                        I would chase that rod down to where it goes. Then I would maybe try holding it to the left (towards the carb) when cranking.

                        DISCLAIMER: I know nothing of this generator and anything/everything you do is at your own risk.
                        Indeed it is. Will see what "tomorrow" brings. Thanks!

                        Comment


                        • #42
                          Re: New RD8000 Starting Problems

                          Okay, now it's running.



                          I siphoned out the gasoline and refueled it back up with the same gasoline. This time it's on the run for twenty (20) minutes now since posting this.

                          Thank you to all!

                          Comment


                          • #43
                            Re: New RD8000 Starting Problems

                            What are you trying to do with the temp gun?

                            Comment


                            • #44
                              Re: New RD8000 Starting Problems

                              Originally posted by PA-Woodchuck View Post
                              What are you trying to do with the temp gun?
                              Sound meter. Yes? No?

                              Comment


                              • #45
                                Re: New RD8000 Starting Problems

                                Originally posted by PA-Woodchuck View Post
                                What are you trying to do with the temp gun?
                                Originally posted by BobsPlumbing View Post
                                Sound meter. Yes? No?
                                Yes! "El Cheapo" Radio Shack Sound Level Meter.

                                Comment

                                Working...
                                X