Announcement

Announcement Module
Collapse

How To Post Images

Want to know the how to upload images to your posts? Image Posting Tutorial
See more
See less

JobMax JigSaw Head

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • JobMax JigSaw Head

    I've owned my JobMax for a short while and just picked up a jobmax jigsaw head attachment (Monday) for it. After installing the head onto the power handle I noticed it has a fair bit of play in the middle of the tool housing. Not the area where it attaches to the tool but in front of that area. I've attached a picture to illustrate where it seems loose. I was wondering if this is normal before I bring it back tomorrow and get it checked.

    Click image for larger version

Name:	ce3c4e6088f0f6d1c2b3b46e34f24bbc.jpg
Views:	1
Size:	58.6 KB
ID:	16895

    I took off the rubber around the base and noticed it appears the housing sits into a metal groove. this is where it appears the play is coming from. When I move the tool this gap will completely close and open as much as in the picture below. Is it possible this gap is causing it to feel sloppy when on the tool? All 4 tabs have this much of a gap.

    Click image for larger version

Name:	648757e8ef3b35a5f56e3c6300444226.jpg
Views:	1
Size:	157.7 KB
ID:	16896
    Last edited by Supermanofsteel; 11-28-2012, 01:49 PM.

  • #2
    Re: JobMax JigSaw Head

    I've had mine for about a year and have used it a few times and have never noticed this. Will keep an eye on it but mine isnt separating as bad as you describe.

    Comment

    Working...
    X