Announcement

Announcement Module
Collapse
No announcement yet.

Pressure Washer won't start

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pressure Washer won't start

    It's the 3000 PSI model. It hasn't been started in about 3 years. I changed the oil and put new gas in it and it wouldn't start. I verified it has spark and have replaced the plug anyway. I can get it to run for 3-4 seconds if I use ether. Otherwise it does nothing. No sputtering or anything.

    My next guess is something gummed up from sitting so long. Should I open it up and try to clean out the carburetor or could something be clogged up in-line? Does this thing even have a fuel filter or just the screen where you put gas in?

  • #2
    Re: Pressure Washer won't start

    The internals of the carb probably dried up, might have to rebuild it. Not sure on your model, but is there a gas on/off switch on the throttle assembly below or above the choke?

    Comment


    • #3
      Re: Pressure Washer won't start

      Originally posted by Alphacowboy View Post
      The internals of the carb probably dried up, might have to rebuild it. Not sure on your model, but is there a gas on/off switch on the throttle assembly below or above the choke?
      Yeah, it's below the choke. I made sure it was on though. How do I get to the carb? Remove the air filter housing and work my way down?

      Comment


      • #4
        Re: Pressure Washer won't start

        Not sure, what model is it, should be on a sticker next to the engine below the pump

        Comment


        • #5
          Re: Pressure Washer won't start

          I would try running some seafoam cleaner thru it to clean out crud in the lines. Sometimes just removing the bowl and moving the float up and down while spraying gumout in the carb will free up the needle and seat.

          Comment


          • #6
            Re: Pressure Washer won't start

            +1 on the Seafoam but after this long a period of time just sitting some disassembly and internal cleaning may also be in order.
            Teach your kids about taxes..........eat 30 percent of their ice cream.

            Comment


            • #7
              Re: Pressure Washer won't start

              Originally posted by Alphacowboy View Post
              Not sure, what model is it, should be on a sticker next to the engine below the pump
              It's the Subaru SP170 engine.

              Thanks for the suggestions so far. I appreciate it, and I'll take any more input you have. I'll have to take a look and see if I can get it apart. Maybe it'll be obvious.

              Comment


              • #8
                Re: Pressure Washer won't start

                Finally got some time to work on this again. I took off the carb and found the smallest jet clogged with dry gas. Everything was dirty so I cleaned it all up then checked flow using an air compressor. Nothing was dried up or brittle so I reassembled.

                Started on the second pull and runs smooth.

                Thanks for the help!

                Comment


                • #9
                  Re: Pressure Washer won't start

                  Next time you go to store it for any length of time, run it dry, disassemble the bowl, and spray some carb cleaner through the intake while holding a paper towel where the bowl was. I do this to "summerize" my snowblower and when I take it out in late fall: always get dark yellow fluid coming out.

                  Comment


                  • #10
                    Re: Pressure Washer won't start

                    A few of my small machines have a drain plug on the carb bowl so I don't have to take the who bowl down, but it's not a bad idea! I like to change the filter since it probably breaks down from sitting in gas so long? Thanks for the update. Frank

                    Comment

                    Working...
                    X