Announcement Announcement Module
Collapse
No announcement yet.
1250LZ clamp loose Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1250LZ clamp loose

    I am a new owner of a 1250LZ miter saw. It was a Christmas present (but I had done some checking and was able to pick out the one I wanted).

    The only thing about the saw that bugs me is that the hold down clamp seems very loose where it mounts on the table. The stud attached to the clamp is tapered, but the hole on the saw is straight, so the clamp wobbles. When I tighten the wood against the fence, it starts to raise up slightly.

    Is this correct? I checked another unit at Home Depot and it was the same, but it seems odd to me that it would be designed that way.

  • #2
    So when you answer you own posting, is that the same as talking to yourself?


    More info:
    I stopped at HD on the way home. The clamp on the 1250lz they had on disply wobbles just like mine. However, on the 10" saw next to it, the clamp fits much tighter. The clamp on the 10" also fits perfectly on the 12". I looked at the pin on the 10" saw, it is straight for about 5/8", then it tapers. The 12" one tapers the entire way.

    Sounds like they put the wrong type of peg on the clamp. I was thinking I might call Ridgid's customer service..

    Comment


    • #3
      Mike,
      I've got the 12" SCMS and the clamp fits pretty snug into the mounting hole on the saw base.
      JJC

      Comment


      • #4
        I noticed it on the SCMS at the store too. It seems like it's only loose on the 12" models. I wonder if they used the wrong piece on the clamp for a certain production run.

        I'm going to get the serial# and try to call Ridgid's customer service tomorrow.

        Comment


        • #5
          I just got the 1290LZ, and mine seems pretty loose, too. I'm going to run over to HD and check out how it is on what they've got set up. It seems awfully wobbly - not exactly a good thing!

          Comment


          • #6
            Well, called Ridgid today to notify them of this problem and I get a recording stating "due to inclimate weather, we are closed today". Must be a heck of a storm to close down Ridgid.

            Comment


            • #7
              A good tool is useless without good customer service/tech support. This is one of the features I take into consideration when I make/have made a purchase. Dealing with a lot of computer related equipment, you might as well use it for a door stop without good customer service/tech support. By the way, last night it iced and snowed 1 foot here on the east coast and I do not know of one business that has closed down, let alone 2 days.

              Anyhow, I got Ridgid on the phone today and they were very nice. Replaced the part with another, more snug clamp.

              Comment


              • #8
                Did you need your serial # when you called? I keep planning to call them, but I keep forgetting to get the serial# before I leave for work..

                Also, how did they do the replacement, send it directly to you, swap it at HD, etc? Any information would be helpful.

                - Mike O.

                Comment


                • #9
                  Mike O'Donnell, sending right to my front door. He did ask for my serial # too. The whole clamp is getting replaced. He is sending one with less taper. Very pleasant gentleman. He also said he was going to check and see with the designers on being a issue.

                  Comment


                  • #10
                    I just called Ridgid tech support. The person I talked to had no information on this issue and was going to check with his supervisor and get back with me. He said this is the first time he's heard anything about this.

                    In case they come back with a different answer than you received, can you give me some specifics of who you talked to? Did you talk to tech support or customer service, and do you have a contact name?

                    Thanks.

                    Comment


                    • #11
                      Nope, the clamp still a no show. Lovely! I have 90 days and if not resolved without giving me too much of a headache, I will not hesitate to take it back.

                      Comment


                      • #12
                        Funny, clamp showed up today and the only difference is the color of the knob, orange. Same issue with it riding up.

                        Comment


                        • #13
                          Well, the last thing they told me was that they were waiting to hear back from "engineering". Maybe something will come of that... I was thinking of seeing if I could get some kind of metal sleeve to put on the bottom of the pin to make it lock in tighter.

                          Comment


                          • #14
                            Anything? Nothing here.

                            Comment


                            • #15
                              Update: they replaced it with the same. It still rides up.

                              Comment

                              Working...
                              X