Announcement

Collapse
No announcement yet.

Lubrication for Miter Saw

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lubrication for Miter Saw

    What does everyone use for lubrication on the belt/drives on the miter saw? I just got done using mine extensively this past weekend, and now when I go to start it up, it squeaks and seems to engage slower than when new. Thanks.
    Nate

  • #2
    What mitre saw do you have that has a belt drive? I thought they were pretty much all direct drive. I could be wrong but that's the impression I got. Thanks,

    Comment


    • #3
      I have the 1290. I am mostly talking about the motor belt that runs up to the saw blade itself. Mine just seems like it needs some lubrication. In the manual, it just talks about adjusting the motor belt tension, but doesn't say anything about lubricating the bearings/pulleys that the belt runs on. I don't think it should ever have to be done, but there is definitely something up with my saw.....
      Nate

      Comment


      • #4
        Sounds like the belt is slipping. Try to adjust the tension as per the manual.
        SSG, U.S. Army
        Retired
        K.I.S.S., R.T.F.M.

        Comment


        • #5
          I agree with TOD. Could be the belt slipping, kind of like when a fan or alternator belt slips a bit in a car and makes a screetching type sound. Might also explain why it engages slower if the belt is slipping and getting a good grab to turn it?

          WWS
          Still enjoying all 10 fingers!

          Comment


          • #6
            I have already messed around with that. That was the first thing I thought of when it started to happen. It seems to me that they are all sealed bearings and should need no maintenance but it still seems to be a problem. hum.....
            Nate

            Comment

            Working...
            X