No announcement yet.


  • Filter
  • Time
  • Show
Clear All
new posts

  • TS3612

    Just finished assemblying my saw - it has a vibration noise on start up and goes away to a smooth quiet running sound. Is this sound a ridgid TS characteristic?

    Love the saw - wondering about the start up sound???????

  • #2
    Big Tim,
    My TS2424 has a little grumble when firing up but I believe it is do to the fact I am putting lots of torque and speed to a blade, arbor shaft, pulley, belt and another pulley that is setting at a dead stop... Once she is fired up it should run very smooth and true...

    You might double check your pulley alignment to make sure you are 100% inline with both pulley faces... It took me a couple of try’s to get it just right.. Many others will tell you the same thing... Most vibration I believe is contributed to pulleys being a hair out of whack... Try a long thin straight edge setting flat to the faces to align… Can’t trust your eye in this case…

    The TS3612 looks to be a very nice saw... I like the improved fence length and bulk that was added... Let us know how the trunion adjustment goes on the new saw... I guess it was improved...
    Regards,<br /><br />Big Johnson<br /><br />Pictures: <a href=\" gallery&file=index&include=view_album.php\" target=\"_blank\"> gallery&file=index&include=view_album.php</a>


    • #3
      Thanks for the info - I will check the pulleys tomorrow. The saw's fence is very solid and bulked up - no play in it at all - dead on accurate after fine tuning it - the trunnions sound very easy to use to adjust blade- haven't checked that out yet. I will let you know if the pullys needed alignment or not.

      Thanks again,