Announcement

Collapse
No announcement yet.

Changing sanding belt assembly question

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Changing sanding belt assembly question

    Hi: I have the Ridgid "oscillating edge belt/spindle sander" (EB4424)and am very happy with its performance during operation. My problem is when changing from belt to spindle I have a heck of a time removing the belt assembly (& when vice versa sometimes trouble reinstalling it). It seems that the flat on the spindle shaft "may" be slightly turned in the assemblys flat causing it to bind a bit. Is this common or is it something I'm doing?
    Thanks for any help!
    Ross

    [ 11-28-2002, 05:26 AM: Message edited by: Ross J ]

  • #2
    I get the exact same thing! I think it's caused by the softer metal on the belt assy. compared to the shaft. Only had mine since Oct. and I'm ready to call 1-800..............

    Comment


    • #3
      Ross,
      I too have a bit of trouble at times removing my belt sander attachment from the shaft. I think it does have a tendency to twist a bit and bind itself together during use.
      The way I have overcome the trouble of getting the attachment off is to, loosen the orange spindle knob about 3/4 of the way off. Then firmly holding the sanding attachment in my left hand, I pop the top of the spindle nut with the palm of my right hand. This will usually free the belt sander from the shaft, then removing the spindle nut the rest of the way and lifting off the belt sander.
      I absolutely love my Ridgid OSS/BS and wouldn't trade it for any of the others I have seen on the market...
      Maybe Jake can give us some advice or input on what he has researched on this topic. I'm sure being the product manager he has stumbled across this a time or two...

      Hope this helps…
      Regards,<br /><br />Big Johnson<br /><br />Pictures: <a href=\"http://www.woodworkersweb.com/modules.php?set_albumName=albuv85&op=modload&name= gallery&file=index&include=view_album.php\" target=\"_blank\">http://www.woodworkersweb.com/modules.php?set_albumName=albuv85&op=modload&name= gallery&file=index&include=view_album.php</a>

      Comment


      • #4
        Thanks for the feedback: I'll try Big Johnson's idea this morning and perhaps try the 800# as well. I'm also concerned about further wear/slop and it's consequences down the road. Sounds like it may be an inherent problem.
        Regards Ross

        Comment


        • #5
          I've done the same a Big Johnson, I have also use some WD-40. I shoot a little down the shaft hold and wipe some on the spindle. So far it has help keep it from getting jammed. I to love the sander. [img]smile.gif[/img]
          Dan<br /> <a href=\"http://community.webshots.com/user/pepaw101\" target=\"_blank\">http://community.webshots.com/user/pepaw101</a>

          Comment


          • #6
            I also have the RIDGID® Oscillating Sander #EB4424 and I have had the same problem with the belt assembly getting stuck on the motor shaft. However, I had the additional problem of the threads getting mucked up on the shaft during my efforts to get the belt assembly off. It appears to me that the problem is that the shaft is steel and the D-shaped hole in the belt assembly is aluminum. The steel seems to dig into the aluminum and then that is all she wrote. The threads on the shaft are left handed so an ordinary thread chaser or dye won't fix the threads. I really like this sander, and there really isn't another like it in the size and price range, but I can't have this thing seizing up everytime I do a large sanding project that needs both the belt and the spindle. Is Ridgid going to provide a fix for this or am I going to have to keep taking the machine back for replacement? Does Big Johnson's solution really work? We can't be the only three people with this problem. I have several other Ridgid tools, and this is the only one that I ever have a problem with. Come on Ridgid, fix this one for all of us...

            Comment


            • #7
              This is obviously a common problem. I experienced the same thing when trying to reinstall the belt sander assembly. Mine was so messed up that I called 1800 and got a new assembly shipped out. I think we need to hear from Jake?

              Comment


              • #8
                Yep I have the same exact problem. It can take quite some time to remove and reinstall the assembly.

                Comment


                • #9
                  Hi: interesting this topic came to life again. I've been using Big Johnson's idea with somewhat improved results but it's still not the right way to have to do things. The sharp edge at the side of the flat spot seems to be digging into the belt assembly hole & doing the damage. I have considered very slightly breaking this sharp edge but so far have been reluctent to do so. My neighbour got the same sander for Christmas & is having the identical problem. As I stated above "sounds like it may be an inherent problem". Also this condition may get worse as time goes on & do damage. It would be interesting to hear some comments from Jake!
                  Regards
                  Ross

                  Comment


                  • #10
                    All,

                    I have heard of a few people with problems as you describe, unfortunately I do not have an ideal fix. My recommended method for removing a stuck sanding assembly is similar to Johnsons. Back the knob off a few turns, lift up on the sanding assembly and rap on the knob with a small hammer. If need be, you can slide a screwdriver between the bottom of the sanding belt and the table surface to help you support the belt assembly.

                    Jake

                    Comment

                    Working...
                    X