Announcement Announcement Module
Collapse
No announcement yet.
New R4511 quit working Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • New R4511 quit working

    I bought a new R4511 on new years eve. Spent new years day assembling the saw and everything went together smoothly. I didn't have time to do to much with it, I just ripped a 2x4 and made a couple of cross cuts. It ran fine. I went out tonight and it is as dead as a door nail. I've tried everything. When I pulled the cover off of the switch, one of the wires had came loose from the switch plugs. I thought this was definitely the problem.

    Sooo I made sure all the wires were making contact and put the cover back on. Still nothing. Can someone tell me how there switch is wired? which colors go where on the switch? It is not shown in the manual. I thought maybe when I put the wires back on, I got them switched or something.

    Any other ideas?

  • #2
    Re: New R4511 quit working

    Page 21 of the repair sheet... has a wiring diagram, but I have not looked to see how detailed it is. Few weeks back another woodworker had a like problem. He was using an extension cord which had a built in circuit breaker which had tripped.

    Best of luck!

    Comment


    • #3
      Re: New R4511 quit working

      I tried another tool on the same outlet and extension cord and it ran fine.
      If someone could remove the cover of their on/off switch and take a picture of the wiring, that would help me a bunch.

      When I first removed this cover, one wire had wiggled loose and another was not making good contact. I'm just afraid I may have accidently switched a wire around on accident and I have no way of checking this.

      Comment


      • #4
        Re: New R4511 quit working

        There might be a circuit breaker built into the motor, that might have tripped (especially if a loose wire on the switch caused some sort of arc)

        Might want to take a look at the motor for a reset button.

        Comment


        • #5
          Re: New R4511 quit working

          There should be a red button to reset the circuit breaker on the motor.
          Here is a wiring diagram from RIDGID Parts.
          Attached Files

          Comment


          • #6
            Re: New R4511 quit working

            I just purchased a new R4511 (Jan 21) and the motor died after less than 5 minutes of very light use. I smelled an electrical burn smell just as the motor started slowing down on it's own... then the breaker on my house electric blew out.

            I reset the fuse and restarted the motor and it tries to get going, but it levels out at a slower speed for a few seconds then blows my house breaker. I removed the belt to see if the motor would run on its own... same deal.

            I have numerous tools in my shop including a 1.5 HP Jet TS, a 2.5 hp router, jointer, etc... I am pretty sure I have a dead motor. Calling Ridgid on Monday.

            Comment


            • #7
              Re: New R4511 quit working

              I have the same problem with my R4511. It ran great for about 7 months, then it would not start without spinning the blade with a piece of wood. Now it will not get up to speed and kicks out the breaker after a few seconds. I called Rigid and they refered me to a local service center, when I called the service center they told me that they no longer serviced Rigid tools because the payback from Rigid was slow or not enough to cover their cost. The person that I spoke to told me that there was a problem with the motors and they had replaced quite a few of them. I finally got to a service center over a hundred miles away and they have ordered a new motor for me under warranty. I will let you know when the new motor arrives. I got the new motor on Friday, only took 4 days to get it. The only problem I had replacing it was getting the set screw out of the pulley. I ended up having to drill out the old one and retapping for a standard 1/4-20. It looked like the original had been locktighted in place. Finally got it running and so far it runs great.
              Fishhawk_1750
              Michigan
              Last edited by fishhawk_1750; 04-10-2010, 09:11 PM. Reason: misspelling

              Comment


              • #8
                Re: New R4511 quit working

                Originally posted by fishhawk_1750 View Post
                I have the same problem with my R4511. It ran great for about 7 months, then it would not start without spinning the blade with a piece of wood. Now it will not get up to speed and kicks out the breaker after a few seconds. I called Rigid and they refered me to a local service center, when I called the service center they told me that they no longer serviced Rigid tools because the payback from Rigid was slow or not enough to cover their cost. The person that I spoke to told me that there was a problem with the motors and they had replaced quite a few of them. I finally got to a service center over a hundred miles away and they have ordered a new motor for me under warranty. I will let you know when the new motor arrives.
                Fishhawk_1750
                Michigan
                That sounds like you may have a bad capacitor, which is an easy and inexpensive fix, so don't toss that bad motor.

                Comment


                • #9
                  Re: New R4511 quit working

                  Don't plan on it. That is the first thing I will do when the new motor arrives. It is allways good to have a backup.
                  Thanks

                  Comment

                  Working...
                  X