Announcement

Collapse
No announcement yet.

TS3650 & Dado Blade problems?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • TS3650 & Dado Blade problems?

    I've had my TS3650 for just over a year. Generally I'm satisfied with it, given the price. I've recently started using a Freud Stacked Dado blade (Freud SD208) and I'm having two problems that I can't solve (and Ridgid Tech Support/Customer Service has been surprisingly unhelpful).
    First problem is that I cannont get good clean-bottom cuts on any type of wood. The bigger the stack (the wider the cut), the more ridges the cuts have. I've read here that on a number of Ridgid TS3650 table saws manufactured recently, the arbors are poorly machined and this causes the dado blades to stack unevenly, producing a less-than perfect cut. My question is this: what's the conventional wisdom for either overcoming this poorly-machined arbor, or for replacing it. Ridgid Tech Support alludes to taking the motor off the saw, shipping it to an authorized service center (at my expense) and waiting an undetermined period of time for it to be replaced. After repeated emails, I still haven't been told WHERE to send it, nor offered any advice in terms of how to package the motor, possible work-arounds, etc. So, are there any readers of this forum who've experienced trouble with stacked dados and would kindly offer suggestions?
    Second question is closely related to the first. The Freud Stacked Dado set I use is generally regarded as a good dado, its well reviewed in woodworking magazines and other woodworkers I know swear by it. However, when I put it on and take it off the TS3650, it is very uncooperative. The outside blades and inside chippers will slide on without much difficulty, but when I have a stack of more than 1/2" or so, it becomes impossible to snug up the individual blades against each other, even without using the arbor washer. I tighten the arbor nut as much as I can without forcing it, yet still the chippers are loose and will spin independently. Has anyone else experienced this, and could you offer any suggestions?
    As I said, I've asked Ridgid Tech Support and they basically refuse to believe I'm having this trouble, and getting any information from them has been like pulling teeth. Had considered the Ridgid Jointer and Ridgid Drill Press, but after customer service like this, I've decided to go with Rikon and Grizzly.
    Thanks in advance for any suggestions you might offer.
    JeffCam

  • #2
    Did you read my response where you posted this same question in another forum?

    "Ridgid Tech Support alludes to taking the motor off the saw, shipping it to an authorized service center (at my expense) and waiting an undetermined period of time for it to be replaced. After repeated emails, I still haven't been told WHERE to send it, nor offered any advice in terms of how to package the motor"

    Why are you talking about shipping the motor? If your arbor is on the motor, that could explain your problem.

    The problem with tightening the dado stack has me baffled. Are you using shims? If so, could the shims be getting hung up in the arbor threads?
    Lorax
    "Did you put the yellow key in the switch?" TOD 01/09/06

    Comment


    • #3
      Are you staggering the tooth alignment or are you mating the teeth against each other. You should be staggering them.
      ================================================== ====
      All of us could take a lesson from the weather. It pays no attention to criticism.

      Comment


      • #4
        Yes, I did stagger the teeth, or stagger the position of the individual chippers so that the teeth of one behind were either in front of, or behind, those of the next blade. When I put on or take off a single 10" blade, the blade goes on and off the arbor without too much difficulty. But when putting the Freud Stacked Dado (SD208) onto the arbor, or taking it off, I really have to fiddle with the blades/chippers to get them on or off. Maybe the arbor hole on the baldes are poorly milled, causing them to hang on the screw threads of the arbor? Or maybe I have a poorly milled arbor? I don't know what else it might be. I've used the same Freud dado set on a delta contractor saw with no problems. If anyone can offer any suggestion, I'd appreciate it. I've about given up on using this otherwise good dado set on this Ridgid TS3650.

        Comment


        • #5
          I have the SD208, and mine is snug going on/off also. I never thought there was anything wrong with the dado or the TS though, I just attributed it to a closer tolerance on the arbor holes in the dado blades and chippers. I have not had any problems with mounting the SD-208 on my TS-3650 such as you describe.

          If you are new to using a dado set, you might want to review this web page with general information on setup and use of a stacked dado blade;
          http://www.newwoodworker.com/usngstkddados.html
          Last edited by Bob D.; 01-20-2006, 06:19 AM.
          "When we build let us think we build forever. Let it not be for present delight nor for present use alone. Let it be such work that our descendants will thank us for, and let us think, as we lay stone upon stone, that a time is to come when these stones will be held sacred because our hands have touched them, and that men will say, as they look upon the labor and wrought substance of them, "See! This our fathers did for us."
          John Ruskin (1819 - 1900)

          Comment

          Working...
          X